[CentOS] Re: Installing Postfix/Dovecot [SOLVED]

Thu Mar 27 23:07:37 UTC 2008
Ned Slider <nedslider at f2s.com>

Giulio Troccoli wrote:
> Giulio Troccoli wrote:
>> I have just installed CentOS 5.1 on my home server and I am trying to 
>> set a mail server.
>> I have diligently followed the instructions on the Wiki - How To on 
>> the CentOS website (http://wiki.centos.org/HowTos/postfix). However I 
>> cannot send internal email (I haven't yet tried externally).
>> Do you have any suggestions on what to check? To test it I used two 
>> normail user: giulio and federica. I logged in as federica and sent an 
>> email to giulio with the mail programme. Is this correct (i.e. using 
>> the mail programme)?
>> There is one thing that I don't quite understand from the 
>> instructions. In section 3.1 it's suggested to set
>> mynetworks =,
>> in the /etc/postfix/main.cf file. My home network however is 
>> and actually the IP assigned to any computers in the 
>> networks start from So I changed mynetworks to 
>> and also (as my server IP address is 
>> actully I don't think this is the cause of my problem 
>> anyway, because it didn't work even with the value suggested by the 
>> Wiki page.
>> Thanks for you help
>> Giulio
> Well,
> after putting the correct settings in /etc/postfix/main.cf
> mynetworks =,
> AND commented out the line
> #mailbox_transport = lmtp:unix:/var/lib/imap/socket/lmtp
> restarted postfix and I can download my email with Thunderbird. I cannot 
> read them on the server with mail but I don't care about that
> Thanks everybody for your help
> Giulio

Hi Giulio,

First up, glad to hear you have it working. I apologize for being late 
to join the discussion - it was just pointed out to me.

I am the author of the postfix/dovecot Wiki guide. If you feel the guide 
is inaccurate or misleading in any way, or any aspects could be improved 
to make it easier to follow or understand, please do not hesitate to 
offer feedback - we are always looking to constantly improve the quality 
of documentation.

I'm not sure why you needed to commented out mailbox_transport = 
lmtp:unix:/var/lib/imap/socket/lmtp, this should have been commented out 
by default unless you'd uncommented it at some point.