[CentOS] USB modem on centos

Tue May 27 17:43:20 UTC 2008
Jerry Geis <geisj at pagestation.com>

I am playing with a USR (us robotics) USB modem model 5637.
in the past I used internal modems and had no issues.
One this unit I plugged it in, dmesg says its recogized.
I did "ln -s /dev/ttyACM0 /dev/ttyS4" this works.
I then did "cu -l /dev/ttyS4" type "AT" and I get OK... looking good.

When I "ATDT my number" I get a connection at 1200 baud (which I should)
and funny characters... I thought looks like a parity thing.
I then did "cu -e -l /dev/ttyS4" type "AT" and I get OK...
Now when I do "ATDT my number" I get a connection at 1200 baud and
I get readable characters.

In the past internal PCI modems I never had to do anything special, just 
the cu -l /dev/ttyS4.
I thought modem to modem handled all that speed/parity stuff and 
computer to modem just always worked
given the correct baud rate.

Does anyone know what the issue might be here. The reason I am asking is 
my program
that talks to the modems (computer to modem) has always been setup for 8 
data no parity
and has always worked. When I use my program on the USB modem it is not 
working and I
assumed from the parity issue above using "cu" to demonstrate. When I 
change my program
to be 7 data bits and even parity it still did not work.

Was wondering if anyone had any USB modem experience on centos and might 
know what is
going on?