[CentOS] Re:Re:Re:Can't get past the splash screen

Fri May 23 05:39:03 UTC 2008
Eon Strife <eon_strife at yahoo.com>

Thanks, I check those folders, and they are already empty.
Now, I tried to remove the freenx by using yum, and then I removed the files it left behind manually in:


along with the nx user and group and reinstall. The problem worsen, no matter what user I tried, I always got Session Startup Failed:

NX> 700 Session id: cluster.hpc.org-1014-084919CE7F9816540BDEDD5A7928084E
NX> 705 Session display: 1014
NX> 703 Session type: unix-gnome
NX> 701 Proxy cookie: ee398e9cedaf3adbba4dc966d4433dee
NX> 702 Proxy IP:
NX> 706 Agent cookie: ee398e9cedaf3adbba4dc966d4433dee
NX> 704 Session cache: unix-gnome
NX> 707 SSL tunneling: 1
NX> 105 /usr/bin/nxserver: line 1077:  8588 Terminated              sleep $AGENT_STARTUP_TIMEOUT
NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1.
NX> 1006 Session status: closed
Can't open /var/lib/nxserver/db/running/sessionId{084919CE7F9816540BDEDD5A7928084E}: No such file or directory.
mv: cannot stat `/var/lib/nxserver/db/running/sessionId{084919CE7F9816540BDEDD5A7928084E}': No such file or directory
NX> 280 Exiting on signal: 15

I tried alternative solution by using VNC. In order to have access to desktop, I modifed the content of the Xstartup file (for the root in /root/.vnc/xstartup and 
for the regular user in /home/EonStrife/.vnc/xstartup) to be :

# Uncomment the following two lines for normal desktop:
# exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#startx &
exec gnome-session &
#twm &

The funny thing is that for regular user I can access the desktop, but for the root I'm only treated with the terminal. (BTW, the client I used are tightVNC and RealVNC)

===Previous Message===

Eon Strife wrote:
> Hi,
> Thanks, it's Gnome, and I'm stuck when I login as root.
> By using Putty, I managed to create a new user, and then I tried to login to desktop(using nomachine) as that user, and yes, it works. The problem now is that I stuck when I login as the root.

> NX> 596 Session startup failed.                                            <- The additional line in the sshlog of the root
> NX> 1004 Error: NX Agent exited with exit status 1.
> Can't open /var/lib/nxserver/db/running/sessionId{0C2C8B077AB56ED37F7A5A72FE8FA7BF}: No such file or directory.
> mv: cannot stat `/var/lib/nxserver/db/running/sessionId{0C2C8B077AB56ED37F7A5A72FE8FA7BF}': No such file or directory
> NX> 1006 Session status: closed
> Exited with status 0. User pressed Ok.

As a regular user you shouldn't be able to look into that directory, 
so that's normal. Only root and nx can do that.

Interesting (at least to me) is that you get an error concerning a 
session that I do not believe it should be looking for. It's like 
it's attempting to reattach to a session that doesn't exist and then 
it fails. I could be incorrect, but at this point it's simply a data 

On the client machine (assuming it is linux), have you removed all 
session data from the user's home directory? By default this is 
~/.nx/cache-unix-windowmanagername (for you that is likely gnome) 
and ~/.nx/letter-hostname-screen-somerandomhashIthink/

Don't remove the config directory or else you'll have to set up the 
nx information again. See if that doesn't fix the issue. It may not, 
and I'm sorry if it doesn't, but I am not entirely sure about this 
particular issue.

If the client machine is a windows machine there is a .nx directory, 
but I am not sure where it's kept. C:\documents and 
settings\user\.nx maybe. That is where it resides on my windows 
install at work on XP. I may or may not have changed the directory 
so you might have to look around a bit.


Alex White
ethericalzen at gmail.com
Life is a prison, death is a release

Send instant messages to your online friends http://uk.messenger.yahoo.com