[CentOS] Correctly setting up sound with Intel High Definition ICH7

William L. Maltby CentOS4Bill at triad.rr.com
Mon Nov 24 10:23:32 UTC 2008

On Sun, 2008-11-23 at 21:51 +0100, Niki Kovacs wrote:
> Hi,
> Earlier this day I started a thread about Skype not working with 
> outgoing sound. Now I wonder if it's not a problem with my soundcard. I 
> had a vague suspicion about this, but since it's way off the original 
> topic, I decided to start a new thread about this.
> Here's what the soundcard looks like:
> [root at grossebertha etc]# lspci | grep -i audio
> 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High 
> Definition Audio Controller (rev 01)
> Actually plain sound (output) works OK. I can use XMMS, MPlayer, VLC and 
> the likes without any problem.
> On the other hand, when I try to record sound over the soundcard, the 
> result is quite fuzzy, full of distortions. I tried to fiddle with 
> alsamixer to get rid of the distortions, but to no avail. Here's what I 
> did to record sound over the mic:
> $ arecord > ~/test.wav

Give a try to the application I used in the thread I reference later in
this reply. Also, have you used settings in arecord for different sample
rates or whatever? Tried it with nice, inverted (i.e. increase priority
rather than reduce priority)?

> Now in the past I configured a laptop with an ICH sound card on it, a 
> small ASUS. I spent like whole afternoons googling and searching through 
> forums, until some day I stumbled over the solution. I had to add 
> something to /etc/modprobe.conf, something like:
> alias snd-card-0 snd-hda-intel
> options snd-hda-intel model=3stack
> ... and all of a sudden sound worked.
> Now maybe there is also a magic line for my new machine (a lenovo 
> desktop PC) that makes the soundcard work correctly for the microphone? 
> But where do I get that information? Guesswork? Google again for a week? 
> Searching for "centos intel high definition sound" doesn't show much.

Since you are now worried about "fuzzy", I don't know if this will help,
but in a thread you started previously,

   Subject: Simple audio recording app

that starts here


in this reply


Did you try this

   Make sure full duplex is enabled in the hardware tab. Open other
   desired things from the krec menu bar. I also opened the alsa mixer and
   made sure all appropriate channels (both in playback and capture tabs)
   are enabled.

The important things I think are the duplex setting and the mixer settings
for enabled stuff.

As for the "fuzziness", since it is only with the microphone, in the
tabs in the alsa mixer, any settings that might affect it? I don't
recall if you confirmed the microphone is good. Have you confirmed
somehow that the problems are not in that or its wires/connectors?

Since this kernel version does not have a preemptive scheduler, maybe
you need to run minimal load while doing the skype stuff? Does top give
a clue that maybe something is hogging the system? Are the Sample rates

Beyond this, I can set up skype in my 5.x or 4.x (if available for 4.x?)
and see what happens.

As I mentioned in the other thread, I'm guessing this is OT for the list.
So if you would like to collaborate off-list, let me know. My time is
limited during the day (EST zone) and I'm working on tax setup in gnucash,
but I should be able to devote a little time off and on.

> Cheers,
> Niki
> <snip sig stuff>


More information about the CentOS mailing list