[CentOS] Firefox distorted printing

Chris Geldenhuis chris.gelden at iafrica.com
Thu Oct 2 07:24:59 UTC 2008

nate wrote:
> Chris Geldenhuis wrote:
>> Hi,
>> I am running a fully updated CentOS 4 box. Since the last few rounds of
>> updates - upgrading to the latest Firefox, I find that I can not print
>> Bank statements etc ( .ps files when saved to disk). The Bank's logo and
>> any lines on the form print OK but the actual content is distorted
>> beyond recognition - printing a series of special characters
>> (!"$%&#'(") instead of transaction descriptions or amounts. Has anyone
>> else experienced this or have a suggestion on how to fix the problem.
> Try printing to a file and use ps2pdf to convert it to PDF and
> validate that the formatting is correct? I always print to a file
> and convert to PDF myself just to have a "hard" electronic copy.
> nate
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
I have tried this - ps2pdf ends with a segmentation fault, I have also 
tried the other suggestions from Les Bell to no avail.

The printer I'm using is a HP Officejet 6313 - there is no exact match 
in the HPJIS driver's list of printer - so I've used the closest match - 
Office Jet 6150. If anyone has a better suggestion I'd be happy to try it.

If this issue cannot be resolved, I will have to revert to FF2.


More information about the CentOS mailing list