[CentOS] kickstart problems

Paolo Supino paolo.supino at gmail.com
Wed Sep 3 07:34:26 UTC 2008

On Tue, Sep 2, 2008 at 8:44 PM, Richard Karhuse <rkarhuse at gmail.com> wrote:

> On 9/2/08, Paolo Supino <paolo.supino at gmail.com> wrote:
>> :
>> Hi Joseph
>>    After sending the last reply I fixed the kickstart config files and
>> added --boot=yes to the network statement of eth0, but going through the
>> consoles of each of the systems to see if the installation completed
>> successfully I found a few that got stuck on the network interface
>> configuration screen (where it asks for IPv4 and IPv6 static/dynamic
>> configuration information: "Configure TCP/IP").
>  I've only been half reading this thread, so feel free to ignore this
> "interruption" ...
> Just plug one and only one NIC into the switch
> Add "ksdevice=link" to your boot-up line (e.g. syslinux.cfg??).
> Configure network (if you must) or just let DHCP take over.
> Kickstart away ....
> (works for me on boxes where during anaconda installation the NICs are
> labeled one way,
> but CentOS running system does another).
> Just a thought ...
>    -rak-
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

  Hi Rak

  I don't ignore anyone :-) To be on topic: the kernel does receive the
parameter ksdevice=bootif from the PXE bootloader. I tried to put eth0
instead of bootif, but it never worked (might be because of other
configuration directives). I've pasted the configuration a couple of times
in this thread so if you look back at one of the messages you will find the
configurations I'm using ...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20080903/47165c34/attachment.htm

More information about the CentOS mailing list