[CentOS] usb irq problem

Mon Sep 22 08:43:35 UTC 2008
Pasi Kärkkäinen <pasik at iki.fi>

On Fri, Sep 19, 2008 at 06:58:21PM +0530, partha chowdhury wrote:
> i add the "irqpoll" option to kernel line. after the system booted i log
> into X with tty1 also login as root with the command " tail
> -f /var/log/messages" for monitoring . After 10 to 20 minutes i got the
> same message again but this time immediately the system froze up !
> i tried it 5 times now and each time is the same result.i also noticed
> that the system was behaving very slowly till the message came up like
> usually folder copy operation - i usually get 70-90MB/s according to
> vmstat 1  comand, but with irqpoll  the maximum i noticed was like
> 10MB/s.
> Am i doing something wrong ?

I'm seeing this same problem on IBM HS21-8853 blades.

It _seems_ like a bug in IRQ routing in BIOS/motherboard.. ACPI issue? 

With IBM blades I'm able to fix the problem by generating the initrd image
with "--without-usb" switch.. this delays the USB module initialization/loading,
somehow fixing the problem.. giving different IRQ to USB controller.

-- Pasi