[CentOS] USB external HDD error messages

Sun Sep 28 23:34:17 UTC 2008
notconfusedaboutthattoday at gmail.com <notconfusedaboutthattoday at gmail.com>

partha chowdhury wrote:
> Guest3731 wrote:
> > Hi - relatively inexperienced user here.  I installed CentOS 5.2 
> > yesterday (http install via a mirror, worked brilliantly), as well as a 
> > new Seagate 1Tb USB external HDD (from the new Xtreme line), for 
> > backup/media storage.
> [snip]
> if you take it out and put it back again is it automatically mounted and 
> can kernel see it when you do fdisk -l ?
Strange.  I took it out and put it back again, and the kernel noticed 
that it was installed:

SCSI device sdf: 1963525168 512-byte hdwr sectors (100205 MB)

And it showed up as sdf when I did fdisk -l.  However, when I ran 
"mount," this is what appeared:

/dev/sde1 on /mnt/seagate1 type ext3 (rw,noexec,nosuid,nodev)
/dev/sde2 on /mnt/seagate2 type ext3 (rw,noexec,nosuid,nodev)

So apparently it's still mounted as /dev/sde1[2], but incorrectly?  Very 
Next, I umounted both /dev/sde1 and /dev/sde2, receiving error messages 
on the console about "lost page write due to I/O error on sde1 [and 2]"

I've re-plugged it, and it's been recognized as /dev/sde.  I ran a 
"mount -a" and it's been picked up by the system.

No clue where to go from here.  Thanks for your help -