[CentOS] Upgrade

Robert kerplop at sbcglobal.net
Wed Apr 1 16:39:08 UTC 2009

Michael A. Peters wrote:
> Mufit Eribol wrote:
>> Michael A. Peters wrote:
>>> Thomas Dukes wrote:
>>>> The error I got when I ran 'yum update' was:
>>>> Error:  Missing Dependency: nss = is needed by package
>>>> nss-devel
>>> Yes, that will do it - devel packages do need to be the same EVR.
>>> Sounds like you figured it out.
>> I have exactly the same problem. No nss-devel is installed currently. 
>> But yum update always gives the below message:
>> ...
>> Package nss-devel.i386 0: set to be updated
>> ...
>> nss = is needed by package nss-devel
>> ...
>> I can't install nss-devel either due to the very same error.
>> Sorry Michael, I still haven't figured it out. No clue at all.
> Sounds like something in your upgrade requires nss-devel but an 
> nss-devel to match the updates nss isn't in the repo, so the update 
> finds the wrong nss-devel.
> What happens when you comment out the mirror list and uncomment the 
> baseurl for both base and updates?
There is strangeness about.
First thing this morning, I see the chatter about updates and after a 
bit did a "yum check-update".  Nothing listed.  I waited and tried, 
waited and tried, finally moved /var/cache/yum out of the way and did 
the check-update again, allowing the cache to rebuild. This time,  I got 
files listed, did a "yum update" and got

    Install     12 Package(s)
    Update     322 Package(s)
    Remove       2 Package(s)

    Total download size: 579 M
    Is this ok [y/N]: n

but had already grown wary and refused the update. Later, I decided to 
do a download only "yum update  --downloadonly 
and it bombed with the nss dependency msg that others have seen. I DO 
have base and update repos enabled.
It appears that the nss and/or nss-devel packages must be playing 
peek-a-boo somehow.  Is it possible that one of the mirrors is short a 
package or maybe has a bad copy?

More information about the CentOS mailing list