[CentOS] Upgrade

Michael A. Peters mpeters at mac.com
Wed Apr 1 15:06:06 UTC 2009

Mufit Eribol wrote:
> Michael A. Peters wrote:
>> Thomas Dukes wrote:
>>> The error I got when I ran 'yum update' was:
>>> Error:  Missing Dependency: nss = is needed by package
>>> nss-devel
>> Yes, that will do it - devel packages do need to be the same EVR.
>> Sounds like you figured it out.
> I have exactly the same problem. No nss-devel is installed currently. 
> But yum update always gives the below message:
> ...
> Package nss-devel.i386 0: set to be updated
> ...
> nss = is needed by package nss-devel
> ...
> I can't install nss-devel either due to the very same error.
> Sorry Michael, I still haven't figured it out. No clue at all.

Sounds like something in your upgrade requires nss-devel but an 
nss-devel to match the updates nss isn't in the repo, so the update 
finds the wrong nss-devel.

What happens when you comment out the mirror list and uncomment the 
baseurl for both base and updates?

More information about the CentOS mailing list