[CentOS] Having trouble installing flash player on centos 5.3 desktop machine

William L. Maltby CentOS4Bill at triad.rr.com
Sat Apr 4 18:56:08 UTC 2009

On Sat, 2009-04-04 at 10:11 -0700, Linda Stark wrote:
> Hi,
> I'm having trouble getting the flash player installed onto my centos
> desktop.
> When i go to the adobe site, I click on the YUM for Linux version,
> then install it, and PC says
> "/tmp/adobe-release-i386-1.0-1.noarch-1.rpm is already installed" -
> but it's not working.
> So then tried downloading the .tar.gz for linux version, and PC asks
> me which program to open to install it, and i don't have a clue.
> Then I try downloading the .rpm version for linux, and my pc says
> "/tmp/flash-plugin- is already installed",
> but it's still not working.
> What am I doing wrong?

I don't know, but what you describe sure doesn't look like my 5.x

> Thanks anyone. 

Being a weekend, the really knowledgeable folks may not be active today.
I would suggest you eventually google and select centos site in the
advanced search page. There's been some threads about plugins recently.
These all a related to Firefox IIRC. I've listed a few things below that
may get you going. If not, "Google is your friend".

What I do know, is this.

$ rpm -q adobe-release-i386

$ rpm -q --whatprovides /usr/lib/flash-plugin

$ rpm -q --filesbypkg flash-plugin-
flash-plugin              /usr/lib/flash-plugin
flash-plugin              /usr/lib/flash-plugin/LICENSE
flash-plugin              /usr/lib/flash-plugin/README
flash-plugin              /usr/lib/flash-plugin/homecleanup
flash-plugin              /usr/lib/flash-plugin/libflashplayer.so
flash-plugin              /usr/lib/flash-plugin/setup
flash-plugin              /usr/share/doc/flash-plugin-
flash-plugin              /usr/share/doc/flash-plugin-

$ locate flash-plugin

In my history file made with

  rpm -qa --last >Desktop/RpmInstalledByDate


  flash-plugin-  Wed 25 Feb 2009 05:19:20 AM EST

Since it has no "el5" of "rf", I presume it came from Adobe, so you are
apparently in the right place.

Nothing like you were describing should ever install in /tmp. /tmp is a
temporary storage area that is subject to arbitrary "cleaning". Maybe
that's the problem? Maybe from a previous attempt a temporary file was
left in /tmp and the new attempt can't overwrite it? I don't know.

I guess the first thing you might want to do is find out where you got
the version that the system says is installed. Then you might want to
remove it - I don't know this - since ISTM that it may be a non-standard

You *may* want to setup the repository for Adobe if you want updates
automatically (or manually) via yum. IIRC, the instructions are on the
web site.

If you do set up the repository and import the gpg key, etc., then a
"yum list available", "yum install <pkgname>", etc. will work for it
just like anything else.

> ______________________________________________________________________
> Rediscover Hotmail®: Get e-mail storage that grows with you. Check it
> out.

No thanks.

> <snip sig stuff>

If you can't get the adobe stuff setup, post back and I'll list my repo


More information about the CentOS mailing list