[CentOS] Using cdrecord on CentOS

Niki Kovacs contact at kikinovak.net
Wed Apr 15 14:46:20 UTC 2009

Michael A. Peters a écrit :

>> 1) Am I supposed to be root to use cdrecord and burn an .iso file?
> I've found it works much better if you are root.

I tried both, and see: cdrecord complains about not being able to set 
certain priorities while being run as user, which induces a high risk 
for buffer underruns. So I have my answer for that.

Another cdrecord-related question. Usually I should be able to copy a CD 
as simply as that:

$ dd if=/dev/cdrom of=copy.iso

Then insert a blank CD, and:

$ cdrecord -v -eject dev=/dev/cdrom copy.iso

Now I did that for data CDs, and it works very well. I thought, normally 
this *should* also work for audio CDs, so I gave that a spin. But 
everytime I try it, dd stops short and gives me an "Input/output error" 
for /dev/hdc.

I tried three different audio CDs, all three in good state. I can listen 
to them OK on the PC. But all I get with dd is a zero-byte-length 
copy.iso file.

Any idea what's happening?


More information about the CentOS mailing list