[CentOS] Using cdrecord on CentOS

William L. Maltby CentOS4Bill at triad.rr.com
Wed Apr 15 14:45:32 UTC 2009

On Wed, 2009-04-15 at 15:46 +0200, Niki Kovacs wrote:
> Michael A. Peters a écrit :
> >>
> >> 1) Am I supposed to be root to use cdrecord and burn an .iso file?
> > 
> > I've found it works much better if you are root.
> > 
> I tried both, and see: cdrecord complains about not being able to set 
> certain priorities while being run as user, which induces a high risk 
> for buffer underruns. So I have my answer for that.
> Another cdrecord-related question. Usually I should be able to copy a CD 
> as simply as that:
> $ dd if=/dev/cdrom of=copy.iso
> Then insert a blank CD, and:
> $ cdrecord -v -eject dev=/dev/cdrom copy.iso
> Now I did that for data CDs, and it works very well. I thought, normally 
> this *should* also work for audio CDs, so I gave that a spin. But 
> everytime I try it, dd stops short and gives me an "Input/output error" 
> for /dev/hdc.
> I tried three different audio CDs, all three in good state. I can listen 
> to them OK on the PC. But all I get with dd is a zero-byte-length 
> copy.iso file.
> Any idea what's happening?

Try padding copied image with a few hundred k of nulls.

dd if=/dev/zero of=copy.iso \
  seek=<number of output blocks to skip forward> bs=2048

I've had to do this for my ISO images depending on the age/brand/model
of the device. It seems that (at least in the past) there was a
disconnect in the kernel handling of the end of file and writing the
last blocks read in. This cured it.

I can't say if this would affect audio CDs as well, but worth a try.

> Niki
> <snip sig stuff>


More information about the CentOS mailing list