[CentOS] DKMS and new(er) Nvidia-drivers

JohnS jses27 at gmail.com
Wed Apr 15 16:52:19 UTC 2009

On Wed, 2009-04-15 at 10:08 +0200, Sorin Srbu wrote:
> >-----Original Message-----
> >From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On
> Behalf
> >Of Michael A. Peters
> >Sent: Tuesday, April 14, 2009 5:57 PM
> >To: CentOS mailing list
> >Subject: Re: [CentOS] DKMS and new(er) Nvidia-drivers
> >
> >> Strangely enough, only the systems running an Amd cpu gives the screen
> >> artefacts. Go figure...
> >
> >What the artifacts?
> >I switched to the DKMS module in rpmforge and am running an AMD CPU.
> >Only think I've noticed is a weird issue with the cursor in thunderbird,
> >I don't know if that is nvidia related or not though. It is annoying and
> >I don't recall it being there before I updated the driver.
> Diagonal thin black lines originating from upper left corner for starters.
> Then if I open a gui, whatever sort, that window gets those lines too. Menus
> are unreadable because of this, but slightly more readable if I move the
> mouse pointer over the menu entry. The lines tend to go away for a short
> while if I log off and log on again. Weird thing is that the lines are
> always diagonal and tend to always originate from the upper left corner of
> whatever window.
> This is with gnome mind you, and *supposedly* this one is the most stable of
> all the desktop environments. Haven't tried with KDE and xfce. Can't tell
> for sure if it's gnome or the Nvidia drivers specifically, but I'm leaning
> towards the drivers.
> It's not a hardware issue, as I've run rhel3 on the same machines w/o any
> artifacts.
> The hardware's two-three year old Asus mobo with a single-core AMD x64 and a
> rather feisty Nvidia Quadra gfx card. Don't have the exact details right
> now, but it should give a hint or two. All the P4-machines, as well as the
> i7-boxes, seem to work fine with dkms.
No none of that is hardware issues. It is issues with the Nvidia Driver
it self.

Some or all of those issues can be solved by Downgrading the driver it
self. All this is in the documentation and are known problems on both
Linux and Windows.


More information about the CentOS mailing list