[CentOS] Is lsb 3.2+ detrimental to CentOS 5.4?

Steve Hamblett steve.hamblett at linux.com
Thu Dec 10 08:01:28 UTC 2009

2009/12/10 MHR <mhullrich at gmail.com>

> I found out today that Google Chrome is now available for Linux.
> However, and this is a big but:
> $ sudo rpm -ivh google-chrome-beta_current_x86_64.rpm
> Password:
> warning: google-chrome-beta_current_x86_64.rpm: Header V3 DSA
> signature: NOKEY, key ID 7fac5991
> error: Failed dependencies:
>        lsb >= 3.2 is needed by google-chrome-beta-
>        xdg-utils is needed by google-chrome-beta-
> $ yum list | grep -i lsb
> redhat-lsb.i386                            3.1-12.3.EL.el5.centos
>  installed
> redhat-lsb.x86_64                          3.1-12.3.EL.el5.centos
>  installed
> I'm not that familiar with lsb, but from what I can find, it does not
> seem like it would be a good idea to install a more recent version of
> lsb than the official release, or am I way off base here?
> I can get xdg-utils easily enough, but it doesn't seem relevant if I
> can't use the newer lsb.
> So, is it possible to use lsb 3.2+ on CentOS 5.4 without breaking
> anything?  Is there anything else I'd need to do, other than convert
> to Fedora (not going to happen)?
> Thanks.
> mhr
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

I tried this yesterday on my 32 bit 5.4 box, installed xdg, removed lsb and
installed the F10 lsb which is 3.2 or higher. This alone doesn't seem to
break anything as such so I then installed the google-chrome-beta rpm. This
installed OK now but when I ran chrome I got this 'libexpat.so.1 not found'
5.4 has version 0.5.0 of this. I stopped here, it looks as though CentOS is
just to far behind the edge for Chrome
Steve Hamblett
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20091210/b92b8def/attachment.html>

More information about the CentOS mailing list