[CentOS] Frustrations with MySQL loss, tcpdump, netstat, etc

Les Mikesell lesmikesell at gmail.com
Tue Dec 22 16:03:57 UTC 2009

ML wrote:
> MySQL 5.0.77 on CentOS 5.4
> MySQL is running, my Wordpress stuff is working, but I cannot connect to the server from my house. This server is in my house, however, but on a public IP, behind a firewall, etc.
> I checked my hardware firewall (a dedicated UnTangle system) and that is successfully allowing the passage. I know this because the firewall shows:
> 2009-12-22 6:29:41 am passed <my IP>:35606 <server IP>:3306
> So, on my server I run tcpdump host <my ip> and I dont think I see anything where 3306 is coming through. 
> if I run a test MySQL connection from the MySQL Workbench and they run netstat on my server
> and I dont see a entry where 3306 is used in what netstat is dumping.
> What am I doing wrong? What can I check for? I am stumped!

Where does the client connection originate?  Is it behind the same 
firewall but on a NATed address?  Or is NAT involved in some other way 
that might keep you from seeing the source you expect in your tcpdump?

   Les Mikesell
    lesmikesell at gmail.com

More information about the CentOS mailing list