[CentOS] SFTP - stalled - on large files

Tue Dec 22 11:12:52 UTC 2009
Sean Carolan <scarolan at gmail.com>

> Tell him to switch WinSCP to SCP mode.
> Kai

Tried that, it still fails the same way.  Here's the short list of
what I've tried to troubleshoot this:

Used SCP via the gui and command line
Used SFTP via the gui and command line
Ran yum update to bring all packages up to date
Tried stock CentOS sshd daemon (version 4.3), as well as sshd built
from source (version 5.3)
Adjusted MTU settings
Reinstalled virtual network card
Updated vmware tools and network card driver
Tried vmxnet as well as e1000 drivers

At this point I don't know what else to try.  I'm thinking that it's
either a problem with VMWare, or perhaps our load balancer that is
routing the packets back and forth.  Hopefully one of the vendors will
be able to help solve the problem.  In the meantime we are building
out a physical server to test whether vmware is the issue or not.

If anyone else has seen this problem before or has suggestions please
post them here.  Thanks.