[CentOS] Can't yum erase/install an app

Robert Moskowitz rgm at htt-consult.com
Wed Jan 7 12:39:49 UTC 2009

I am switching the box that I did the HIPL rpm builds over to running 
from rpms built directly by the HIPL team 

I did the 'make uninstall' and then 'yum install hipl-all', but the 
hipl-firewall rpm did not install.  Seems like I have a mess on my 
system with the various hipfw files.  I 'manually' deleted a bunch of 
them (perhaps a mistake), and then tried 'yum install hipl-firewall' and 
it reported that it was installed.  So I tried a 'yum erase 
hipl-firewall' and got two errors:

hipfw: unrecognized service
error reading information on service hipfw: No such file or directory

Then I get a 'Removed: hipl-firewall.i386 0:1.0.4-1' and a 'Complete!'.

I then do a 'yum install hipl-firewall' and get that it is installed and 
there is nothing to do....

Well, it is not installed, but there is something in yum that says it is 
installed.  What to do?  man yum does not show any options to force the 
install.  So how do I get around this foobar?

More information about the CentOS mailing list