[CentOS] (Semi-OT) Problems with Firefox

partha chowdhury kira.laucas at gmail.com
Tue Jan 13 03:28:32 UTC 2009

Sam Drinkard wrote:
> List,
>     After I think the last or next to last update to firefox, I started 
> seeing some problems, wherein I no longer have a "back" function on any 
> pages or tabs.  Also, I get some kind of strange message....
>  "Assertion Failed ASSERT:***Search:_installLocation: engine has no 
> file! Stack Trace: 0 ENSURE_WARN(false,_installLocation: engine has no 
> file!.2147500037) 
> 1:()2:()3:()4:90:epsGetAttr([objectObject],hidden)5:906:907:currentEngine() 
> 8:get_currentEngine()9:updateDisplay() 10:init() 11:([object XULElement],0)
>     I realize this is not the proper place for FF related problems, but 
> thought I'd ask if someone else has seen something like this happen.  
> Prior to the last 2 updates, FF appeared to be working properly, and all 
> the forward/back buttons worked.
i recall i had almost the same problem as yours some weeks back. One 
fine morning there was no back button for any page

in addition the awesomebar of ff3 was not working i.e it was not 
completing urls and i was not getting fullscreen even after pressing F11 
numerous times. i tried disabling the flash and java plugins and also 
the other plugins but nothing worked. Then

i created a second ff profile from backup and till date that problem has 
not resurfaced yet. so i now run two profiles side-by -side one being a 

> rpm -q firefox
> firefox-3.0.5-1.el5.centos

> [freedom at desktop ~]$ sudo grep -i firefox /var/log/yum.log*
> Password:
> /var/log/yum.log:Dec 25 08:37:00 Updated: firefox - 3.0.5-1.el5.centos.i386
> /var/log/yum.log.1:Sep 26 18:16:54 Updated: firefox - 3.0.2-3.el5.centos.i386
> /var/log/yum.log.1:Nov 15 11:03:30 Updated: firefox - 3.0.4-1.el5.centos.i386
> /var/log/yum.log.2:Aug 30 22:16:08 Updated: firefox - 3.0.1-1.el5.centos.i386

More information about the CentOS mailing list