[CentOS] Yum update conflicts perl-Math-BigInt

Scott Silva ssilva at sgvwater.com
Fri Jan 30 21:36:57 UTC 2009

on 1-30-2009 1:13 PM Dan Carl spake the following:
> I followed the Wiki instructions for setting up *yum-priorities*.
> I added the rpmforge repo
> I installed clamd without a problem.
> Now when I go to update I get conflicts with perl-Math-BigInt.
> Is the only solution to uninstall the base version and then install the 
> rpmforge version?
> According the the wiki
> "Packages from repositories with a lower priority will never be used to 
> upgrade packages that were installed from a repository
> with a higher priority."
> If this true why the conflicts? please advise
> Thanks
> Dan
Sometimes you will get conflicts if the new package doesn't have a
corresponding base package but was built into the base's monolithic rpm. I
don't think base has a separate package for that module, but has it as part of
the base perl rpm.

If you really need the newer version you might have to --force it. Or you can
see if the version in base perl is OK for your needs.

MailScanner is like deodorant...
You hope everybody uses it, and
you notice quickly if they don't!!!!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 258 bytes
Desc: OpenPGP digital signature
Url : http://lists.centos.org/pipermail/centos/attachments/20090130/3603e4aa/attachment.bin 

More information about the CentOS mailing list