[CentOS] prettyprint problem in CentOS 5.2

Mon Jan 19 19:17:49 UTC 2009
tbuchanan at vinu.edu <tbuchanan at vinu.edu>

I'd like to ask for help with a problem in CentOS 5.2 when printing from 
the command line with the prettyprint option selected.  Program students 
print out their code with the command:

lpr -P<printer_name> -o prettyprint -o job-sheets=none 

The prettyprint option, as you know, puts a banner with file name and date 
at the top, and uses a small font, and (for a color printer) uses 
different colors for different parts of the file.  This last worked with a 
fully updated CentOS 4.7 server but after a move to a different fully 
updated CentOS 5.2 server the prettyprint option does nothing unless the 
first line of the file to be printed contains /*hello*/, (discovered quite 
by accident).  CUPS on CentOS 4.7 was cups-1.1.22-0.rc1.9.27.el4_7.1 while 
the version on CentOS 5.2 is cups-1.2.4-11.18.el5_2.3.  I tried printing 
from a couple other Linux distros, Fedora 10 (cups-1.3.9-6.fc10.i386) and 
Ubuntu 8.04 LTS, both of which were fully updated.  The Fedora 10 
exhibited the same problem while the Ubuntu 8.04 LTS printed properly with 
the prettyprint option.  Is this a bug with the way RedHat implements CUPS 
or am I missing something?  The only thing I found in a quick Google 
search that was similar (but with opposite effects, if I understand 
correctly) was this CUPS bug report http://www.cups.org/str.php?L2158 
which gives no resolution.  For now the instruction is having the students 
print via a script he created which adds \*hello*\ to the first line of 
their code.  Any help would be appreciated.