[CentOS] Cannot open port 631 for Cups printer sharing

Mon Mar 2 19:14:35 UTC 2009
Scott Silva <ssilva at sgvwater.com>

on 3-2-2009 8:20 AM b.j. mcclure spake the following:
> I have been trying to set up printer sharing on the LAN.All machines are
> CentOS 5.2 fully updated. The problem server is a fresh build.  The box
> it is replacing worked fine for many months.
> The problem appears to be a closed port 631 on the new box.  iptables
> and ip6tables are stopped as shown by the output below.  To confirm I
> was using nmap correctly I ran it against the old server first which
> shows 631 open.  No matter what I do to the new box ( 631
> remains closed.  I was running it on the new box via ssh which I think
> eleminates any swithc/router issues.
> Any thoughts gladly accepted.  This must be something simple/stupid I
> have overlooked.  Not much hair left to pull out. ;-/

Cups defaults to only being open on localhost. You have to edit the config
file to open more up.

MailScanner is like deodorant...
You hope everybody uses it, and
you notice quickly if they don't!!!!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 258 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/centos/attachments/20090302/77c74959/attachment-0003.sig>