[CentOS] Cannot open port 631 for Cups printer sharing

Mon Mar 2 19:22:43 UTC 2009
JohnS <jses27 at gmail.com>

On Mon, 2009-03-02 at 11:14 -0800, Scott Silva wrote:
> on 3-2-2009 8:20 AM b.j. mcclure spake the following:
> > I have been trying to set up printer sharing on the LAN.All machines are
> > CentOS 5.2 fully updated. The problem server is a fresh build.  The box
> > it is replacing worked fine for many months.
> > The problem appears to be a closed port 631 on the new box.  iptables
> > and ip6tables are stopped as shown by the output below.  To confirm I
> > was using nmap correctly I ran it against the old server first which
> > shows 631 open.  No matter what I do to the new box ( 631
> > remains closed.  I was running it on the new box via ssh which I think
> > eleminates any swithc/router issues.
> > 
> > Any thoughts gladly accepted.  This must be something simple/stupid I
> > have overlooked.  Not much hair left to pull out. ;-/
> > 
> Cups defaults to only being open on localhost. You have to edit the config
> file to open more up.
Qouted by me earlier:
>Interesting that when the local host address is used the port is open:
>[root at rwells-rh legacydp]# nmap -sT -p 631 -PT
"""It is configured by default to it has to be changed"""  # Maybe they
did not understand my wording of it? Should have said It has to be
changed for networking.
Posted a working networkable config also and linked the cups site also