[CentOS] Cannot open port 631 for Cups printer sharing

Mon Mar 2 20:46:09 UTC 2009
b.j. mcclure <keepertoad at bellsouth.net>

On Mon, 2009-03-02 at 14:22 -0500, JohnS wrote:
> On Mon, 2009-03-02 at 11:14 -0800, Scott Silva wrote:
> > on 3-2-2009 8:20 AM b.j. mcclure spake the following:
> > > I have been trying to set up printer sharing on the LAN.All machines are
> > > CentOS 5.2 fully updated. The problem server is a fresh build.  The box
> > > it is replacing worked fine for many months.
> > > The problem appears to be a closed port 631 on the new box.  iptables
> > > and ip6tables are stopped as shown by the output below.  To confirm I
> > > was using nmap correctly I ran it against the old server first which
> > > shows 631 open.  No matter what I do to the new box ( 631
> > > remains closed.  I was running it on the new box via ssh which I think
> > > eleminates any swithc/router issues.
> > > 
> > > Any thoughts gladly accepted.  This must be something simple/stupid I
> > > have overlooked.  Not much hair left to pull out. ;-/
> > > 
> > 
> > 
> > Cups defaults to only being open on localhost. You have to edit the config
> > file to open more up.
> Qouted by me earlier:
> >Interesting that when the local host address is used the port is open:
> >[root at rwells-rh legacydp]# nmap -sT -p 631 -PT
> """It is configured by default to it has to be changed"""  # Maybe they
> did not understand my wording of it? Should have said It has to be
> changed for networking.
> Posted a working networkable config also and linked the cups site also
> JohnStanley
I think the first problem is we have somehow merged two threads.  The
first was Mr. Wells issue which is different from mine.  His port 631 is
"open" when nmap is run from localhost but not when run against the IP.
My port 631 is closed regardless of whether it is run from localhost or
remotely against the IP.  My cupsd.conf works.  An identical machine
co-located has an identical cupsd.conf and shares the same printer
nicely on the same LAN.  The same nmap configuration run against that
machine shows port 631 open in both above cases.  My conclusion, FWIW,
is that it is not a cups config issue but a port issue.  

Also, the cups site link confirms that @LOCAL means local network which
is all I'm looking for.  The laserjet 1300 has been supported for at
least a few years now.

CentOS 5.2, Linux 2.6.18-92.1.22.el5 x86_64 15:26:24 up 22:20, 4 users,
load average: 0.10, 0.08, 0.03