[CentOS] hplip problems - configure: error: "cannot find libjpeg support"

Mon Mar 16 18:36:43 UTC 2009
Roger Wells <ROGER.K.WELLS at saic.com>

Anne Wilson wrote:
> On Thursday 12 March 2009 15:59, Roger Wells wrote:
>> Anne Wilson wrote:
>>> On Thursday 12 March 2009 14:45:27 Roger Wells wrote:
>>>> I actually did install the home printer last night (Photosmart C6180).
>>>> "hp-setup' ran fine, discovered the printer and installed it just as it
>>>> did for the LJ4350 (it didn't find the correct PPD file but...).
>>>> The good news is that even though hp-toolbox won't run the Centos
>>>> Scanner Tool works.
>>>> It discovered the scanner correctly and I was able to operate with it as
>>>> expected.  The scanner is also available within appropriate applications
>>>> such as OpenOffice and the Gimp.
>>>> So maybe we don't need hp-toolbox so much after all.
>>> Glad you got it working, Roger.  I knew I wouldn't have time to have
>>> another go at this until tomorrow.  So did you use the 3.9.2 version? 
>>> Anything to report about the actual installation?
>> yes the hplip version is 3.9.2.   First I removed the installed version
>> which was 1.6.7, I think.  Then I followed the
>> directions at:
>> http://hplipopensource.com/hplip-web/install/manual/distros/centos.html
> I finally made time to try this again.
>> This went well but the "hp-check" near the end indicated two or three
>> errors that would show up at run-time were
>> present.  These are some of what we have been discussing in this thread
>> and are apparently the ones that will prevent
>> "hp-toolbox" from running.  They do not apparently affect "hp-setup".
>> .
> I can't run either hp-toolbox or hp-setup (it complains that it can't run the 
> gui) but I could run 'hp-setup -i' which gives a text install.  I thought I 
> might as well follow through the whole kaboodle, but when it got to setting 
> up fax headers it complained (again!) that  python-dbus is not installed.  It 
> then said
> warning: Qt/PyQt 4 initialization failed.
> error: hp-setup requires GUI support (try running with --qt3). Also, try using 
> interactive (-i) mode.    (which is what  I'd just done.)
>> Run hp-setup as root (the only way) and it should find your printers.
>> For each of mine a warning was issued:
>> error: No PPD found for model laserjet_4350. Trying old algorithm...
> I saw that too - but then it continued and installed PPD file: 
> foomatic:HP-PhotoSmart_7150-hpijs.ppd.  I'm fairly sure that that is the 
> wrong driver.  The HP-PhotoSmart_C series are not the same as the 
> HP-PhotoSmart series.  The C7100 driver is correct, the 7100 driver does not 
> work.  Fortunately the device/queue that I installed under CUPS is still 
> available to me.
>> In the case of the C6180 this resulted in all printing going to 4x6 inch
>> pages to a printer that only had photograph
>> page size options.  When offered to search for PPD files during
>> installation you can take that route and search
>> in /usr/share/ppd/HP for a more appropriate driver.  Why "hp-setup"
>> doesn't find drivers there I don't know.
>> I had to select the one with the ".gz" extension to avoid an error about
>> a missing "foomatic-rip-hplip" something
>> or other.  You can apparently do this "PPD" changeover after installation.
>> I did that with the C6180.  If it still insists on printing in a 4x6
>> format I will report back.
>> As I said earlier the Centos 5.2 Scanner Tool seems to work just fine.
> I can't see the scanner at all, but then xsane seems to bomb out on me.
> I don't actually need it on this box, and to tell the truth, I can't spare any 
> more time on it.  If it was important I'd use the HP Launchpad to get it 
> fixed, but I'm just going to bale out now.
> I'm glad you got a working solution.
good luck Anne,
my situation got a little more bizarre.  The C series driver never 
worked.  At some level perhaps it did because test page's that
I printed would never come out, until I rebooted then they would all 
come on out.  The foomatic 7150 driver was never offered to me but I 
tried it and it seems to work although I don't think faxing does. 
And scanning still seems fine.  For this to work it was necessary to 
install via HPLIP.
roger wells
> Anne
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Roger Wells, P.E.
221 Third St
Newport, RI 02840
401-847-4210 (voice)
401-849-1585 (fax)
roger.k.wells at saic.com