[CentOS] OT: centos.org web site not responding

Sat Mar 21 03:49:20 UTC 2009
Lanny Marcus <lmmailinglists at gmail.com>

On Fri, Mar 20, 2009 at 10:05 PM, Ross Walker <rswwalker at gmail.com> wrote:
> On Mar 20, 2009, at 6:35 PM, Lanny Marcus <lmmailinglists at gmail.com>
>>>> Probably this thread should die, until more people cannot
>>>> surf the site. That's what I'm getting, although I can ping it and
>>>> traceroute to it. As I said, it's an intermittent problem. Lanny
>>> I haven't even seen one try at showing a tcpdump or similar.

Ross: I have an old (2003) book about Network Troubleshooting. It
shows an example of using Telnet to Port 80, to see what's happening.
I just tried that, and assuming the CentOS server in Layered Tech is
configured the same way, which is a huge assumption, it is not
responding with HTML. However, I also tried that, to one of my web
sites, on a shared server in CT, (I had them disable Telnet and
Anonymous FTP) and it does not respond with HTML there either. My
browser can load my web site without any problem.   Probably this is
*NOT* a valid way to test this!  Here's what I got, in my 3 attempts:

[lanny at dell2400 ~]$ telnet 80
Connected to (
Escape character is '^]'.
Connection closed by foreign host.
[lanny at dell2400 ~]$

I did not type the GET command and it eventually timed out

[lanny at dell2400 ~]$ telnet 80
Connected to (
Escape character is '^]'.

I got no response after that and no HTML content. This is the example
in the book.

[lanny at dell2400 ~]$ telnet 80
Connected to (
Escape character is '^]'.

I got no response after that and no HTML content

> It may be a blackhole router between you and the website. Some path
> that has a slightly smaller MTU but has ICMP disabled so the need to
> fragment messages aren't sent.

When I use the  mtr -c 10 -r centos.org someone suggested yesterday,
which John Pierce said might not be meaningful with this problem,
within Layered Tech, I *always* see one hop in Dallas, with "???"  and
a 100% loss.     What does that mean, if anything, with this problem?

ae_cw_10g.databank.com                        0.0% 113.5 113.7 110.4 116.0   1.9
pod22h_ae.layeredtech.com                     0.0% 115.2 114.3 112.5 115.4   1.0
???                                          100.0   0.0   0.0   0.0   0.0   0.0  10.0% 113.4 113.0 111.4 115.6   1.4
[root at dell2400 ~]#

> Try pinging with a 1500 byte packet and see if it reaches. If it
> doesn't decrease the size until it does and you then know what the
> short MTU size is and you can set that as your MTU on your outside
> interface of your router. A "workaround" solution.

I used this command: ping -s 1500 centos.org and it does work OK. I
get back 1508 bytes, which I believe is correct.

Please give me the exact command you want me to try, if that isn't it!
  I have been thinking about MTU, vaguely remembering things I did
years ago, during the past few days.

The problem went away, for approximately 24 hours,  after Tru filed
the initial Trouble Ticket at Layered Tech, but it came back, a day or
two later and now I know that Layered Tech didn't change anything and
if it is on Level3 as the LT tech thought, they are probably unaware
of a problem on their network. It's intermittent from my end. I was
able to load the web pages from centos.org on Tuesday after the
Trouble Ticket was filed at LT and on Wednesday as I recall and then
yesterday, no joy again.

Your time and help, and that of everyone else in this thread, are much