[CentOS] OT: centos.org web site not responding

Sat Mar 21 04:12:09 UTC 2009
John R Pierce <pierce at hogranch.com>

> Ross: I have an old (2003) book about Network Troubleshooting. It
> shows an example of using Telnet to Port 80, to see what's happening.
> I just tried that, and assuming the CentOS server in Layered Tech is
> configured the same way, which is a huge assumption, it is not
> responding with HTML. However, I also tried that, to one of my web
> sites, on a shared server in CT, (I had them disable Telnet and
> Anonymous FTP) and it does not respond with HTML there either. My
> browser can load my web site without any problem.   Probably this is
> *NOT* a valid way to test this!  Here's what I got, in my 3 attempts:

insufficent info on your GET, and you can't use any backspaces, you 
pretty much have to paste a perfect command...

$ telnet www.centos.org www
Connected to www.centos.org (
Escape character is '^]'.
Host: www.centos.org

HTTP/1.1 200 OK
Date: Sat, 21 Mar 2009 04:08:16 GMT
Server: Apache/2.0.52 (CentOS)
X-Powered-By: PHP/4.3.9
Set-Cookie: PHPSESSID=d329988a9d984ee4bbe2e1e2f12d2aa0; path=/
Expires: Mon, 26 Jul 1997 05:00:00 GMT
Cache-Control: private, no-cache
Pragma: no-cache
Connection: close
Content-Type: text/html; charset=ISO-8859-1

Connection closed by foreign host.

note i had to send THREE lines...     I used the HEAD command rather 
than GET so I don't have to stare at a bunch of html.

    HEAD / HTTP/1.1
    Host: www.centos.org

(and a blank line to terminate the request)