[CentOS] freetype-2.2.1-21.el5_3.src.rpm rebuild failure

Frank Cox theatre at sasktel.net
Fri Nov 20 20:55:24 UTC 2009

On Fri, 20 Nov 2009 15:19:35 -0500
Kwan Lowe wrote:

> Maybe this:
> https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath

I'm missing something.

In the freetype.spec file I made this line:

%configure --disable-static

look like this:

%configure --disable-static --disable-rpath

I got the same error as before when I tried to compile it.

I then added the following two lines immediately after the configure line, so
it looks like this:

  %configure --disable-static
  sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g'
libtool sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool

That didn't work either -- I got an error telling me that it can't find
libtool, and that was it.

The frustrating part of this is that I have found some webpages that discuss
how to recompile exactly this srpm and it apparently works for them.

Example here:

I don't see what I am doing wrong, or why this isn't working for me.

MELVILLE THEATRE ~ Melville Sask ~ http://www.melvilletheatre.com

More information about the CentOS mailing list