[CentOS] freetype-2.2.1-21.el5_3.src.rpm rebuild failure

Frank Cox theatre at sasktel.net
Fri Nov 20 22:59:06 UTC 2009

On Fri, 20 Nov 2009 14:55:24 -0600
Frank Cox wrote:

> I don't see what I am doing wrong, or why this isn't working for me.

I seem to have gone from a rebuild failure to an installation failure.

Looking at this spec file:


I copied what appeared to be the relevant lines out of that into the
freetype.spec that I have in my rpmbuild/SPECS directory, so now the "Build
Freetype 2" section looks like this:

# Build Freetype 2
  %configure --disable-static
  sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g'
builds/unix/libtool sed -i 's|^runpath_var=LD_RUN_PATH|
runpath_var=DIE_RPATH_DIE|g' builds/unix/libtool

  make X11_PATH=/usr %{?_smp_mflags}

That actually worked and it built me this in my RPMS/x86_64 directory:

freetype-2.2.1-21.x86_64.rpm            freetype-demos-2.2.1-21.x86_64.rpm
freetype-debuginfo-2.2.1-21.x86_64.rpm  freetype-devel-2.2.1-21.x86_64.rpm

Dandy, I thought.  Since the ATI proprietary driver web page states that it
requires the i386 stuff on an x86_64 machine, and since I appear to have both
i386 and x86_64 versions of freetype installed, I did my build again using
--arch-i386.   And again, it worked:

freetype-2.2.1-21.i386.rpm            freetype-demos-2.2.1-21.i386.rpm
freetype-debuginfo-2.2.1-21.i386.rpm  freetype-devel-2.2.1-21.i386.rpm

Interestingly enough, to install these I had to use the --oldpackage parameter
in the rpm command, otherwise it told me that a newer package was already


rpm -U rpm -U --oldpackage i386/freetype-2.2.1-21.i386.rpm

And all appeared to be well.  I then logged out and the fun started.  gdm
crashed.  Here is what it says in /var/log/messages:

Nov 20 16:42:38 mutt kernel: gdm-binary[32281]: segfault at 00000000f5d8bd84
rip 00002b883bd87ee6 rsp 00000000f5d8bd78 error 6

Lots and lots of lines that tell me that, over and over.

Logging in at a text console and running "yum update" brought me back to a
working system again.

The only thing I'm trying to do is to enable the bytecode interpreter on this
system.  So far, it's a failed attempt.

MELVILLE THEATRE ~ Melville Sask ~ http://www.melvilletheatre.com

More information about the CentOS mailing list