[CentOS] Sendmail "Queued mail for delivery"

Alexander Dalloz ad+lists at uni-x.org
Sun Nov 22 13:00:00 UTC 2009

Timothy Murphy schrieb:
> Larry Brower wrote:
>>> I see that mail sent from a remote computer
>>> never leaves the computer,
>>> the last entry in /var/log/maillog being
>>> "Queued mail for delivery".
>> The message was accepted. You failed to supply sufficient information to
>> troubleshoot further.
> Thanks for your response.
> I think I have solved the problem.
> The trouble was that I put my home address in the From line,
> and the ISP in Italy rejected the mail on that account.
>>> 2. Where incidentally is the mail queued for delivery?
>>> I don't see it in /var/cache/ .
>> Have you looked in /var/spool ?
> I did actually look there,
> but /var/spool/mail/tim and /var/spool/mqueue/ were empty.

Hi Timothy,

taking the information from your other posting of this thread you were
using the sendmail binary to send the message. This leads to using the
submission mechanism (that's ok and standard).

The MSP accepted your message - thus the "queued mail for delivery" log
note - and tried to send it out using the MTA daemon part of your
sendmail installation.

Until this is successful the message is kept queued in
/var/spool/clientmqueue, to be queried by

mailq -Ac

While running just "mailq" the MTA queue (/var/spool/mqueue) is checked
for messages and the reason why a delivery is postponed is shown as well.

If you have messages queued and want to see some more output from the
delivery process you can run

- for the MSA processing: sendmail -Ac -q -v

- for the MTA processing: sendmail -q -v

The information is printed on stdout.

Btw. /var/spool/mail/tim is the mailbox (inbound) spool of user tim.
Messages in there will not be processed by sendmail any longer as they
are delivered.

Best regards


More information about the CentOS mailing list