[CentOS] CentOS 5 and DRPM

Janez Kosmrlj postnalista at googlemail.com
Mon Nov 30 10:32:51 UTC 2009

I finally managed to do it.
I had to rebuild the latest createrepo package from sourcerpm:
wget http://createrepo.baseurl.org/download/createrepo-0.9.8-1.src.rpm
rpm2cpio createrepo-0.9.8-1.src.rpm | cpio -idmv --no-absolute-filenames
change yum dependency to yum >= 3.2.22 in the spec file
rpmbuild -bb createrepo.spec
install freshly build createrepo package
install deltarpm from epel
createrepo --database  --deltas -s sha --oldpackagedirs ../base/ .

deltarpm from epel
rebuild yum-presto >= 0.4
rpmbuild --rebuild
install fresh yum-presto package
in your updates yum repos conf file add deltarpm=

On Mon, Nov 30, 2009 at 10:05 AM, Farkas Levente <lfarkas at lfarkas.org>wrote:

> On 11/27/2009 11:14 AM, Janez Kosmrlj wrote:
> > OK I figgured out the client part. But unfortunately this was the easy
> part.
> > I still can't figure out, what i'm doing wrong on the server.
> > I tried installing deltarpm package from epel and the newest createrepo
> > package from atrpms (deltarpm from here won't install because it is
> > build against a newer rpm package and I don't like to change the rpm
> > package on my system).
> > But when i run:* /createrepo --database  --deltas  -s sha
> > --oldpackagedirs /dir /dir/* i get some obscure python errors, that I
> > can't figure out.
> >
> > I tried the same commandon on an fedora 11 machine wiht the default
> > fedora packages installed and it works without problems. As far as i can
> > see the versions of createrepo on fedora and centos (the atrpms package)
> > are the same. the only different part is the python version, but that
> > shouldn't be the problem, since I looked at the .spec file from
> > createrepo and it only requires python 2.1 and centos has 2.4.
> >
> > Does someone have a newer createrepo rpm package, that works on centos?
> you need newer createrepo and yum-presto:
> http://www.lfarkas.org/linux/packages/centos/5/i386/other/RPMS/
> and don't set checkum eg i used to use this command:
> -----------------------------------------
> createrepo -c /var/cache/createrepo -d --update --checkts --skip-stat
> --deltas --oldpackagedirs <dir> <dir>
> -----------------------------------------
> of course create a /var/cache/createrepo before run, or if you've time:
> -----------------------------------------
> createrepo -d --deltas --oldpackagedirs <dir> <dir>
> -----------------------------------------
> --
>   Levente                               "Si vis pacem para bellum!"
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20091130/a8c43d7a/attachment.html>

More information about the CentOS mailing list