[CentOS] NFS freeze when transmitting big files

Sun Apr 4 12:13:06 UTC 2010
JohnS <jses27 at gmail.com>

On Sat, 2010-04-03 at 17:22 +0200, Niki Kovacs wrote:
> JohnS a écrit :
> > 
> > You should have better success with another 128MB of RAM..
> > 
> > Case point I have one also a P3 450 256MB RAM CentOS 5.4 here at home
> > using samba + clam av and large files make me have to hard mount the
> > directory to paste to the server.  I run no GUI either on it so you may
> > want to get rid of X and Gnome.  Mine I run in, run level 3 so no gui
> > here because it was painfully slow.
> I had some time this weekend to check this out. I found another 128 MB 
> RAM, put it into the server (and tested it OK). I took the server to my 
> office and connected it directly to the main switch, to rule out 
> networking bottlenecks.
> I opened up 'top' on the server and switched to memory display (Shift-O, 
> O, Enter).
> On my desktop PC I transferred a bunch of files, and memory usage 
> instantly went from around 110 MB to 250 MB, and then it began to swap 
> and left the transfer with a steady 4800 k/s stream.
> So I guess it was effectively a problem of missing RAM.
> Cheers,
> Niki
Yea although CentOS 5 can be ran with 128 I promise you want be happy
with it.  I think in my initial post to you I neglected to include I
have clamav-samba running also.  All my media files I had to confiigure
the cifs shares for clam-av to not scan them.  i do come to find out I
have a lil more than 256MB of ram but not by much.  I do have every
service I do not need cut off.  Also mine swaps also.  You should get
better spped than what your getting.  I can't get no more than 10MB/s.
My smb global config may help some.

top - 08:12:13 up 13 days,  4:55,  1 user,  load average: 0.00, 0.00,
Tasks:  70 total,   1 running,  69 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.3%us,  0.3%sy,  0.0%ni, 99.3%id,  0.0%wa,  0.0%hi,  0.0%si,
Mem:    385356k total,   380516k used,     4840k free,     4372k buffers
Swap:   655352k total,       68k used,   655284k free,   330532k cached


max xmit = 65535
disable netbios = yes
socket options = TCP_NODELAY SO_KEEPALIVE SO_RCVBUF=524288 \
write raw = yes
read raw = yes
oplocks = no