[CentOS] CentOS5 and samba

Mon Apr 19 12:52:24 UTC 2010
Les Mikesell <lesmikesell at gmail.com>

lhecking at users.sourceforge.net wrote:
> Daniel Bird writes:
> [...] 
>> However, at the risk of being a pedant, that doesn't give us a 
>> explanation as to why the same setup on  CentOS & RHEL resulted in the 
>> behavior we experienced. NFS mounts are surely not that uncommon on 
>> samba servers and one would expect the locking mechanisms to cope with 
>> that scenario. It surely does on our old Solaris box. We will be 
>> investiaging this further since our migration is going to take a couple 
>> of months and like JD pointed out in a previous post the no locking 
>> option shouldn't be needed.
>  I found these
>   http://kbase.redhat.com/faq/docs/DOC-1984
>   http://lists.samba.org/archive/samba/2009-May/148403.html
>  and we're in the situation described (NetApp filer with no CIFS license).
>  Investigating one of our sites with a working CentOS5 samba server shows
>  that they indeed have "posix locking = no" in smb.conf.
>  The bit that is still unclear to me, however, is that RH apply this to all
>  of RHEL3,4,5, whereas we don't see this problem under RHEL3.

What about the default options that have changed?  Have you tried setting them 
back to what worked with RHEL3?  Be sure you are running nfsv3, udp, etc.

   Les Mikesell
    lesmikesell at gmail.com