[CentOS] creating partitions on a 2.7TB drive

Joshua Baker-LePain jlb17 at duke.edu
Tue Feb 23 15:47:45 UTC 2010

On Tue, 23 Feb 2010 at 3:38pm, Khusro Jaleel wrote

> Now, after a few months I forgot all about the Ubuntu LiveCD and tried 
> to setup server "B" using the CentOS 5.3 x86_64 CD. However the 
> installer immediately complained that "this disk in using a GPT 
> partition table and this computer cannot boot using GPT" and it keeps 
> saying this no matter what I do. I've tried creating a separate /boot 
> partition, using LVMs for everything, etc but nothing works, even "dd" 
> did not give me much luck, although perhaps I should try deleting the 
> "end" of the disk rather than the beginning?

There are 2 facts at play here:

1) Any device larger than 2TB must use a GPT disklabel.

2) You cannot boot from a device with a GPT disklabel.

None of the tricks you mention above will work.  What you need to do is 
use the RAID card BIOS to divide the array into multiple devices.  Most 
decent RAID cards will either "auto-carve" arrays into <2TB chunks or let 
you create a small "boot-drive".  The latter is preferable, IMO.  If your 
RAID card doesn't offer such an option, then you'll need to either remove 
some disks from the array to use as boot drives or add more drives to the 

> The additional mystery is that if I check server "A" which I partitioned 
> a few months ago using Ubuntu, the "label" type is "msdos"!! How is that 
> possible? In addition if I use the CentOS CD and try to use parted on 
> server "A" now, it gives the following error:

Weird things happen when trying to boot from GPT labeled devices, 
including all sorts of data-loss scenarios.

Joshua Baker-LePain
QB3 Shared Cluster Sysadmin

More information about the CentOS mailing list