[CentOS] Running Asterisk & Freepbx on readonly Root (Stateless System)

Christopher Chan christopher.chan at bradbury.edu.hk
Thu Jan 14 00:23:48 UTC 2010

Alok Prasad wrote:
> Hi 
> I am trying to Run AsteriskNow 1.5 which uses Centos 5.3 Distribution 
> with Readonly Root Filesytem.
> Right now if I shutdown the system abrupty or there is power failure 
> linux kernel 
> doesn't not boot "Kernel panic" and other short of issues.prb due to 
> corrupted files.
> Thats why i want to make root filesystem as read-only and placing some 
> directories
> /var and /etc/asterisk etc as read/write in fstab so above 
> problem doesn't exists.
> Centos Provides fantastic experimental technolyg with only a single line 
> configuration to 
> root read-only and make it boot /etc/sysconfig/readonly-root file
> Edting /etc/sysconfig/readonly-root  ->  change READONLY=no to READONLY=yes
> */
> /*
> I tried but i am not able to run asterisk and freepbx.Linux system boots 
> up properly.
> Any one has ever tried this ..Any suggestion how to proceed with.

First run as read write and then use lsof to see what files asterisk and 
the freepbx stuff opens and get those sorted. Or increase logging for 
asterisk and check for the errors it reports.

More information about the CentOS mailing list