[CentOS] perl question

m.roth at 5-cent.us m.roth at 5-cent.us
Fri Jan 29 19:40:14 UTC 2010

> I am trying to run a perl script that said it needs Net::SMPP
> I ran this:
> your_host]# *perl -MCPAN -e shell*
> cpan shell -- CPAN exploration and modules installation (v1.76)
> ReadLine support enabled
> cpan> *install Net::SNMP
> seemed to work. no errors reported.
> however when I run perl I still get the same error saying needs
>  ./sendmessage.pl
> Can't locate Net/SMPP.pm in @INC (@INC contains:
> /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi
> /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi
> /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl
> /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .)
> at ./sendmessage.pl line 18.
> BEGIN failed--compilation aborted at ./sendmessage.pl line 18.
> What else do I need?

Two possibilities - but first, did you type the asterisk before install?
Anyway, did cpan *say* that it had successfully installed? I've had things
fail, and have to go into .cpan/Build/<path>, and make;make install. The
other possibility is that for some reason, it's not where it needed to be,
and you might try yum install Net-SNMP


More information about the CentOS mailing list