[CentOS] perl question

Greg Patton greg at csfm.com
Fri Jan 29 19:44:05 UTC 2010

On 1/29/2010 11:40 AM, m.roth at 5-cent.us wrote:
>> I am trying to run a perl script that said it needs Net::SMPP
>> I ran this:
>> your_host]# *perl -MCPAN -e shell*
>> cpan shell -- CPAN exploration and modules installation (v1.76)
>> ReadLine support enabled
>> cpan>  *install Net::SNMP
>> seemed to work. no errors reported.
>> however when I run perl I still get the same error saying needs
>>   ./sendmessage.pl
>> Can't locate Net/SMPP.pm in @INC (@INC contains:
>> /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi
>> /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl
>> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi
>> /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl
>> /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .)
>> at ./sendmessage.pl line 18.
>> BEGIN failed--compilation aborted at ./sendmessage.pl line 18.
>> What else do I need?
You need to learn how to actually read the output of error messages. :-) 
It states very clearly what it failed on and that loading the module 
Net::SMPP (Can't locate Net/SMPP.pm)! Change the use line in your script 
to read use Net::SNMP and I will be you it works like a hot darn.

Don't ya hate when you miss the obvious? :-)


More information about the CentOS mailing list