[CentOS] Skype and problem with ALSA mixer driver?

Ned Slider ned at unixmail.co.uk
Sat Jan 30 01:40:40 UTC 2010

Andrew wrote:
> On Fri, 2010-01-29 at 11:03 -0800, Akemi Yagi wrote:
>> On Fri, Jan 29, 2010 at 10:44 AM, Andrew <andy.allen at virgin.net> wrote:
>>>> What version of ALSA driver are you using? Have you tried updating ALSA
>>>> as the version within CentOS is quite old now (1.0.14rc3).
>>>> Elrepo has an updated ALSA driver package here:
>>>> http://elrepo.org/tiki/kmod-alsa
>>> Thanks for that useful information, but can you tell me exactly how to
>>> perform the update? I tried 'yum update *alsa*' as I have the Elrepo
>>> repository installed, but it came up with 'No Packages marked for
>>> Update'. Do I need to completely remove all the currently installed ALSA
>>> packages and then do 'yum install kmod-alsa? Any advice gratefully
>>> received, thanks.
>> Perhaps, you do not have elrepo enabled (default behavior) ?  In that case, try:
>> yum --enablerepo=elrepo install kmod-alsa
>> Akemi
> Many thanks,
> I've installed kmod-alsa OK but the mic is still not working (with
> skype). Do I need to remove the old ALSA packages alsa-lib and
> alsa-utils? - because when I type 'yum erase alsa-lib alsa-utils' it
> wants to remove 123 packages!
> Andy

No, do *not* remove alsa-lib or alsa-utils (they are core CentOS packages).

Have you rebooted since installing kmod-alsa as the kernel will need to 
load the new drivers? If not, please reboot and retest.

If it's still not working after updating ALSA using kmod-alsa from 
elrepo (after a reboot), then you might want to consider removing that 
package as it hasn't fixed the problem in your case:

yum erase kmod-alsa

Hope that helps.

More information about the CentOS mailing list