[CentOS] Skype and problem with ALSA mixer driver?

Andrew andy.allen at virgin.net
Sat Jan 30 18:42:44 UTC 2010

> No, do *not* remove alsa-lib or alsa-utils (they are core CentOS packages).
> Have you rebooted since installing kmod-alsa as the kernel will need to 
> load the new drivers? If not, please reboot and retest.
> If it's still not working after updating ALSA using kmod-alsa from 
> elrepo (after a reboot), then you might want to consider removing that 
> package as it hasn't fixed the problem in your case:
> yum erase kmod-alsa
> Hope that helps.

Thanks for that advice - I've rebooted and tested again but, although
the playback sound is absolutely fine the mic still doesn't work - when
I try the 'skype testing service' I just get some faint buzzing sounds
instead of (my) intelligible speech. OK, I'll remove kmod-alsa if it
obviously hasn't cured the problem, but where does that leave me? I've
only had this problem since I upgraded to CentOS 5.3 - skype worked
absolutely fine with CentOS 5.0, so I'm wondering if anybody else has
experienced this with CentOS 5.3? I don't particularly want to go back
to CentOS 5.0, but I'm pretty frustrated that I can't use skype at the
moment because it's such a useful communication facility. If I'm going
to stick with CentOS (5.3), isn't there something else I can upgrade to
solve this problem?


More information about the CentOS mailing list