[CentOS] DSL battling rojter - help!

Sun Jul 18 14:58:02 UTC 2010
Mark <mhullrich at gmail.com>

Sorry about the "j" - dvorak artifact....

Okay, let me try again.

First, here's my (new) /etc/hosts file:

# Do not remove the following line, or various programs
# that require network functionality will fail.       mhrichter localhost localhost.localdomain
#  mhrichter mhrichter.adsl.irvine.sbcglobal.net
::1             localhost6.localdomain6 localhost6

If I run ifup eth0, here's what I get:

eth0    Link encap:Ethernet  HWaddr 00:1E:90:F3:D2:8D
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::21e:90ff:fef3:d28d/64 Scope:Link
          RX packets:5557646 errors:4 dropped:0 overruns:0 frame:4
          TX packets:3497153 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:7118384647 (6.6 GiB)  TX bytes:413380509 (394.2 MiB)
          Interrupt:153 Base address:0xc000

With this setup, I can login to the DSL modem, which shows the
following configuration:

DSL	                UP
Connection	UP
User ID	        xxxxxxx at sbcglobal.net
Connected at	1536 Kbps (downstream)
		        384 Kbps (upstream)
IP Address
IP Gateway
DNS Servers dnsr1.sbcglobal.net
Mode		PPP on the modem (Public IP for LAN device)
Timeout	        Never
Modem Information
Modem Name	SpeedStream
Model		4100
Serial Number	20013A3E0A514
Software Version1.0.0.53
MAC Address	00:13:A3:E0:A5:14
First Use Date	2006/10/31 00:38:02 GMT
Local Network
Modem IP Address
Ethernet Status		Connected

In this shape, I can ping, say, google.com from the modem and get a response.

But, when I run dhclient, I get this:

# dhclient
Internet Systems Consortium DHCP Client V3.0.5-RedHat
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

/sbin/dhclient-script: configuration for vmnet8 not found. Continuing
with defaults.
/etc/sysconfig/network-scripts/network-functions: line 78: vmnet8: No
such file or directory
Listening on LPF/vmnet8/00:50:56:c0:00:08
Sending on   LPF/vmnet8/00:50:56:c0:00:08
Listening on LPF/eth0/00:1e:90:f3:d2:8d
Sending on   LPF/eth0/00:1e:90:f3:d2:8d
Sending on   Socket/fallback
DHCPREQUEST on vmnet8 to port 67
DHCPREQUEST on eth0 to port 67
bound to -- renewal in 291 seconds.

And after that I can't reach the modem or the internet.  If I run
ifdown eth0 and then ifup eth0, I get the IP address
back, and I can reach the modem, but not the internet.

(So I'm back on the Windows machine to send this.)

This probably seems pretty basic to many of you, but I'm still a
neophyte at the details of IP under Linux.  IOW, I'm lost.  None of
this was any kind of problem before I reset/mangled the router.

One other question: I notice that the router claims to be,
but so does the modem.  Could that be part of the problem, i.e.,
should I change the router's IP address to something else?  I remember
it was before the fiasco....

Thanks again.