[CentOS] Audio fails on centos 5.5 sony laptop - snd-hda-intel [Solved]

Fri Jul 23 02:43:54 UTC 2010
Rob Kampen <rkampen at kampensonline.com>

Akemi Yagi wrote:
> On Wed, Jul 21, 2010 at 3:20 PM, Rob Kampen <rkampen at kampensonline.com> wrote:
>> Rob Kampen wrote:
>> I have started to setup an rpmbuild environment but need to read some more
>> instructions, as when I followed the wiki I got different results - not sure
>> if this is due to using the centosplus SRPM, as that is what all my
>> workstations use, or due to my error in following instructions.
>> When I tried the make oldconfig after copying the config file as indicated I
>> ended up having to respond to lots of option questions that I have no idea
>> about, thus I'm likely to select an option that causes problems.
>> I thought make oldconfig was a process to dump out the current config
>> settings so they could be used as a template for the new
>> build......confused.
> Because you are starting with a centosplus kernel and cplus kernels
> are already customized, you do not have to go through the
> customization part of the wiki instruction.  In your case, all you
> have to do it to remove one patch.
> I see the patch to be removed is this one:
> Patch24883: linux-2.6-sound-alsa-hda-driver-update-for-rhel5-5.patch
> Therefore, look for the line:
> %patch24883 -p1
> and delete it (it is line 9753 in the current kernel). If you had
> already modified the .spec file, I suggest you start fresh. The only
> other change you would want to make is "buildid" to provide a unique
> name for your new kernel.
> Good luck!
Well firstly let me thank all those who have done such an excellent job 
with Centos, and the wiki.
I have managed to rpmbuild my first ever kernel minus the patch - and it 
installed and booted just fine.
A real tribute to all the centos team and particularly those that have 
taken the time to document the howto pages.

Unfortunately that particular patch is not the issue - sound still 
didn't work.
So I went back and looked at dmesg and found that snd-usb-audio is 
loading first and as modprobe.conf had no specific instructions about 
this device driver it installed it as card 0 - thus when it subsequently 
tried to load snd-hda-intel as card 0 it failed.
My initial fix was to edit modprobe.conf and make the snd-hda-intel as 
card 1.
Reboot and now the card shows up okay and sound worked.
Using the System > Administration > Soundcard Detection configurator 
showed both devices as it did for the 164 and earlier kernels.
The settings tab allows one to change the order of devices. Looking at 
the modprobe.conf produced by this procedure yielded the following :-
options snd cards_limit=8
alias snd-card-0 snd-hda-intel
options snd-hda-intel index=0
alias snd-card-1 snd-usb-audio
options snd-usb-audio index=1

thus now I have specific instruction to load the snd-usb-audio as device 
1 and thus snd-hda-intel can load as device 0.
why this worked okay without the two lines for snd-usb-audio on 164 
(5.4) kernels is a mystery to me.
I hope this may be of help to others that suddenly find sound devices 
failing to perform as expected.

All in all a learning experience.
Thanks to Ned and Akemi for getting me headed in the right direction.

> Akemi
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

-------------- next part --------------
A non-text attachment was scrubbed...
Name: rkampen.vcf
Type: text/x-vcard
Size: 123 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20100722/2f5d5e61/attachment-0003.vcf>