[CentOS] Audio fails on centos 5.5 sony laptop - snd-hda-intel [Solved]

Fri Jul 23 03:57:09 UTC 2010
Akemi Yagi <amyagi at gmail.com>

On Thu, Jul 22, 2010 at 7:43 PM, Rob Kampen <rkampen at kampensonline.com> wrote:

> The settings tab allows one to change the order of devices. Looking at the
> modprobe.conf produced by this procedure yielded the following :-
> <snip>
> options snd cards_limit=8
> alias snd-card-0 snd-hda-intel
> options snd-hda-intel index=0
> alias snd-card-1 snd-usb-audio
> options snd-usb-audio index=1
> thus now I have specific instruction to load the snd-usb-audio as device 1
> and thus snd-hda-intel can load as device 0.
> why this worked okay without the two lines for snd-usb-audio on 164 (5.4)
> kernels is a mystery to me.
> I hope this may be of help to others that suddenly find sound devices
> failing to perform as expected.
> All in all a learning experience.
> Thanks to Ned and Akemi for getting me headed in the right direction.

You are quite welcome. Glad to learn you've got things sorted out. I'm
sure your solution would help future searchers having the same