[CentOS] how to get ASUS USB-N13 802.11n net adapter working on 5.5?

R P Herrold herrold at owlriver.com
Tue Sep 28 13:11:56 EDT 2010

On Tue, 28 Sep 2010, Robert P. J. Day wrote:

>  there is a CD that came with the adapters, with a Linux directory,
> so it was easy enough to dump that onto my personal centos 5.5 box,
> and run "make" which generated the loadable "rt3070sta.ko" module.
> and, yes, that module loads.  so far, so good.

If the module builds and loads cleanly when done manually, you 
are half way home  ;)

>  however, that still doesn't do it as based on what i've read
> online), because the access point here uses WPA/WPA2, i need to
> use wpa_supplicant to be able to configure the wireless interface for
> that.  and that's about when i got kicked out of the classroom as they
> were closing for the evening.

heh -- wpa_supplicant is 'lightly' documented, and the process 
for getting a wholly text mode wireless connection, and 
auto-selecting between open and secure with WPA or WPA2 AP's 
seems like a dark art.  The following is from memory as the 
unit in question is not physically on, and not remotely 
reachable at the moment

[As a bit of background, I was tempted by the price of an 
'e-machine' box, while travelling and a laptop died while on 
the road -- the darn thing takes non-CentOS 'wl' Broadcom 
wireless drivers, and the 'atl1c' wired network driver, of 
which I solved one manually, and the other one with a package 
from El Repo
     	/me waves to that fine effort ]

It turns out not to be a 'dark art' to get wireless networking 
on the darn thing after all, but it was not trivial, either. I 
reading man pages, tailing logs, stracing stuff, and so forth. 
Most of the effort ended up in getting the configuration 
correct in /etc/wpa_supplicant/wpa_supplicant.conf AND having 
to add a custom add on initscript, and did edits in 
/etc/sysconfig/wpa_supplicant to get the whole shebang working 
properly and hands off

Quick answer is that a script to this effect ran at step S98, 
and basically:
        	stopped networking
        	stopped a running wpa_supplicant
        	rpmmod'd an instance of my locally compiled wireless
        		driver module
        	re-loaded said custom wireless driver module
        	# [ at this point the driver REALLY loaded ]
        	[re]started the wpa_supplicant
        	[re]started the networking

and dhcp, and the wireless supplicant basically did a:
        	iwlist eth0 scan

... which then walked the enumeration of ESSID's and looked 
for a match in /etc/wpa_supplicant/wpa_supplicant.conf  Once 
found, wpa_supplicant hands along the required credential, 
and 'magic happens'

I assume there are various GUI goop tools to this effect, but 
I am not much of a GUI person ;)

I'll try to remember to write this up more formally.  Hope 
this helps

         .-- -... ---.. ... -.- -.--
Copyright (C) 2010 R P Herrold
              herrold at owlriver.com
           My words are not deathless prose,
              but they are mine.

More information about the CentOS mailing list