[CentOS] new kernel = no working sound

Sun Apr 10 20:27:41 UTC 2011
Iulian L Dragomir <iulianld at gmail.com>

On Sun, Apr 10, 2011 at 10:52 PM, Iulian L Dragomir <iulianld at gmail.com> wrote:
> On Sun, Apr 10, 2011 at 10:15 PM, Rob Kampen <rkampen at kampensonline.com> wrote:
>> I found that there was another module loading before the snd-hda-intel
>> thus I added index=0 to the one I needed and index=1 to the other module
>> that seemed to get in the way.
>> the clue was looking under System>Administration>Sound Card Detection and
>> seeing the  Audio configuration dialog > Settings tab - it showed my desired
>> sound card as number 1 rather than 0 with another item as number 0 (one I
>> did not even know was on the computer).
>> Took me a recompiled kernel and hours of wasted time. Old kernels all worked
>> fine - thus I thought it was a kernel patch problem - removed all the
>> related patches and still no joy.
>> I do not know what they are doing to the kernel but over time the loading of
>> modules, order of disk detection etc is becoming much more of an issue.
> Thank you for your explanations and for the suggestions.
> Unfortunately i only have a single device in Sound Card Detection >
> Audio configuration dialog > Settings tab so the snd-hda-intel is
> number 0.
> Patching and recompiling the kernel is over my level of expertise.
> For the moment i will continue to use
> kernel#2.6.18-194.26.1.el5.centos.plus at least the next kernel update
> will appear.
> Elrepo and kmod-alsa provided by them is the next thing on my "to do"
> list (the clue is coming from oracle compatible kernel .. in the
> release notes they mention that they updated alsa-hda drivers) .  . If
> the problem is solved by this i well see in short time.

Problem solved by:
yum --enablerepo=elrepo install kmod-alsa

I do hope that the next centos kernel will work out of the box but
till then i will use the above solution

Thanks to everyone for suport