[CentOS] kernel panic on 5.6

Tue Apr 19 15:26:18 UTC 2011
Jerry Geis <geisj at pagestation.com>

Jerry Geis wrote:
> ok - so I am getting the kernel panic in my (kickstart PXE invironment).
> I have used this environment since cents 5.2
> The PXE starts up 5.6 gets installed that all works fine.
> then after it reboots I get the kernel panic cant mount root (0,0)
> This is just one disk SATA nothing special. Same hardware I have 
> always used.
> I not have booted into rescue mode. my /etc/grub.conf looks fine.
> everything else looks fine.
> I have tried 3 different machines now. All three get the same result.
> I have not changed anything in my kickstart environment from 5.5 to 
> 5.6 other
> than change numbers from 5.5 to 5.6.
> What am I looking for? as I mentioned grub looks fine.
> Thanks,
> Jerry
I looked at all the grub stuff in the editor mode and it looked fine. 
root was hd0,0 etc...
I booted in rescue mode and was looking around.  ls -l /boot all files 
are there
however the initrd-2.6.18-238.9.1.el5.img is only  50 bytes  not the 
normal 2.6M

How is this getting corrupted???

I did "grep initrd kickstart*" and nothing showed up  so it would appear 
as though I am
not changing it.

Thanks for any thoughts.