[CentOS] kernel panic on 5.6

Tue Apr 19 15:40:40 UTC 2011
Peter Kjellström <cap at nsc.liu.se>

On Tuesday, April 19, 2011 05:26:18 PM Jerry Geis wrote:
> Jerry Geis wrote:
> > ok - so I am getting the kernel panic in my (kickstart PXE invironment).
> > I have used this environment since cents 5.2
> > The PXE starts up 5.6 gets installed that all works fine.
> > then after it reboots I get the kernel panic cant mount root (0,0)
> > This is just one disk SATA nothing special. Same hardware I have
> > always used.
> > 
> > I not have booted into rescue mode. my /etc/grub.conf looks fine.
> > everything else looks fine.
> > 
> > I have tried 3 different machines now. All three get the same result.
> > 
> > I have not changed anything in my kickstart environment from 5.5 to
> > 5.6 other
> > than change numbers from 5.5 to 5.6.
> > 
> > What am I looking for? as I mentioned grub looks fine.
> > 
> > Thanks,
> > 
> > Jerry
> I looked at all the grub stuff in the editor mode and it looked fine.
> root was hd0,0 etc...

The "root (hdXXX,YY)" line was never in question (without it no kernel had 
been found and you'd not gotten the "unable to mount root" panic.

What could have been wrong was the "root=..." part of the kernel line in grub. 
But as it stands now it seems more likely that mkinitrd failed during install 

> I booted in rescue mode and was looking around.  ls -l /boot all files
> are there
> however the initrd-2.6.18-238.9.1.el5.img is only  50 bytes  not the
> normal 2.6M
> How is this getting corrupted???

Sounds like the installer for some reason did not succeed to generate an 
initrd for your setup. Any clues if you run mkinitrd on the machine manually? 
(preferably with verbose option)

Except for this manual invocation of mkinitrd it would also be nice to (as a 
previous poster suggested) run the install a bit more interactively to see 
what goes wrong.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.centos.org/pipermail/centos/attachments/20110419/0dda23db/attachment-0003.sig>