[CentOS] rhel nfs bug with 5.5 - nfsd: blocked for more then 120 sec

Wed Apr 27 18:20:26 UTC 2011
aurfalien at gmail.com <aurfalien at gmail.com>

On Apr 18, 2011, at 12:46 PM, Les Mikesell wrote:

> On 4/18/2011 2:01 PM, aurfalien at gmail.com wrote:
>> Hi all,
>> I ran into this bug on my NFS server which is serving an XFS fs;
>> https://bugzilla.redhat.com/show_bug.cgi?id=616833
>> It was suggested using bind mounts.
>> My current fstab on my server is;
>> /dev/sdc1	/SHARE	xfs	defaults,noatime,nodiratime,logbufs=8,uquota	1 2
>> Unsure how to integrate bind mounts in this scheme to see if I can
>> avoid this bug until it is fixed.
>> Any ideas?
> That's not the mount that matters.  The suggestion had to do with
> loopback mounts where the same machine is a client.  Those could be  
> bind
> mounts, symlinks, or just pointed directly at the real location  
> instead.
>  If you aren't doing that you might just need more memory.

Hi Les,

Just a quick follow up.

I ran into the issue a few times after posting and noted that I was  
not short on memory.

I did update to 5.6 and the problem seems to have gone away.

I'm not real comfortable trying a bind mount as suggested in that bug  
report as I can't really understand what it means to bind mount a  
local volume.

- aurf