[CentOS] Install CentOS as KVM guest

Thu Apr 28 06:17:03 UTC 2011
Emmanuel Noobadmin <centos.admin at gmail.com>

On 4/28/11, Jussi Hirvi <listmember at greenspot.fi> wrote:
> I tried it too, didn't work. Try virt-install without creating the image
> first. Virt-install will create the image (type "raw") on the go. If you
> want qcow2, you can convert the image later. Qcow2 has some special
> features but is slower than raw.

I'll give that a spin next, although the disks file I created are RAW
as well. The problem wth using virt-install to create files is that it
takes forever, I've no idea why.

> No, I definitely did not do that. I don't know why that would be needed.

That's what I'm puzzling over. But reading up so far seems to imply
that it acts as a way for qemu/KVM to receive and inject network
traffic into the kernel network stack.

> The double slash does not look good... On next try, try it with no slash
> at the end of ip, and no slash at the beginning of path. (But keep the
> last slash.) :-)

The installer adds that double slash, it was one of the first oddity I
noted. But googling indicates that this was normal and testing it,
indicates that the URL was valid. I suppose it just meant root of root
which is still root :D

Anyway I tried out different variations just to be safe, but whether I
used /Centos56 or Centos56 or Centos56/, the same url comes up. The
installer apparently does some basic sanitization of the parameters.

>> So it seems to me that the VM's networking is wrong somehow.
>> Especially since the assigned IP is not pingable during this point.
>> But I can't be sure if that's just because the OS is still being
>> installed.
> I would not expect ping to work at that point. I would do
> 	virsh destroy myvm
> 	virsh undefine myvm
> 	virt-install again...

Those 3 are my most familiar vir* command at this point :D

As for the httpd log you mentioned in another email, that's also one
of the reason I keep suspecting that networking is the issue. There
are no entries in the httpd logs for the guest, but I can see my
external access entries.