[CentOS] Install CentOS as KVM guest

Thu Apr 28 07:54:09 UTC 2011
Jussi Hirvi <listmember at greenspot.fi>

> On 4/28/11, Jussi Hirvi<listmember at greenspot.fi>  wrote:
>>>  Try virt-install without creating the image first.

On 28.4.2011 9.17, Emmanuel Noobadmin wrote:
> I'll give that a spin next, although the disks file I created are RAW
> as well. The problem wth using virt-install to create files is that it
> takes forever, I've no idea why.

For me creating the images does not take any noticeable time. Only when 
the installer formats the "disk" to ext3 (or others), it will take some 
time. Probably your syntax does not work. Try the syntax in my example, like

--disk path=/kvmail/mail.img,size=290 \

(making sure that the image does not exist beforehand).

>> >  No, I definitely did not do that. I don't know why that would be needed.
> That's what I'm puzzling over. But reading up so far seems to imply
> that it acts as a way for qemu/KVM to receive and inject network
> traffic into the kernel network stack.

You are probably reading some outdated howtos. No wonder, because where 
are the up-to-date howtos?? Red Hat Virtualization Guide is a nice book, 
but only an overview - it does not go into the gritty details.

>> >  The double slash does not look good... On next try, try it with no slash
>> >  at the end of ip, and no slash at the beginning of path. (But keep the
>> >  last slash.):-)
> The installer adds that double slash, it was one of the first oddity I
> noted. But googling indicates that this was normal and testing it,
> indicates that the URL was valid. I suppose it just meant root of root
> which is still root :D

I just got the double slash too on one installation try. I believe the 
double slash is an error of the error messaging. :-) If so, it only 
shows the level of "sophistication" of virt-install.

> Anyway I tried out different variations just to be safe, but whether I
> used /Centos56 or Centos56 or Centos56/, the same url comes up. The
> installer apparently does some basic sanitization of the parameters.

So it should. But that only "sanitizes" the error message, and 
erroneously (producing a double slash). :-)

I am just installing CentOS 4. I tried it first without a trailing slash 
in the path, and I got instantly "unable to get the image" or so. After 
that I could not get the image again, whatever I did. I had to restart 
the install from scratch, and then, after being sure to add the trailing 
slash, I got the image at once.

If this is problem in Anaconda or virt-install, I am not sure.

> As for the httpd log you mentioned in another email, that's also one
> of the reason I keep suspecting that networking is the issue. There
> are no entries in the httpd logs for the guest, but I can see my
> external access entries.

Ok, that could be the case.

- Jussi
Jussi Hirvi * Green Spot
Suvilahdenkatu 1 B 78 * 00500 Helsinki * Finland
Tel. +358 9 493 981 * Mobile +358 40 771 2098 (only sms)
jussi.hirvi at greenspot.fi * http://www.greenspot.fi