[CentOS] KVM guests failed to start after 6.2 upgrade

Thu Dec 22 16:26:05 UTC 2011
Paul Heinlein <heinlein at madboa.com>

On Wed, 21 Dec 2011, Emmett Culley wrote:

> I tore my hair out for a while after rebooting into 6.2 because none 
> of the VM guests would start.  After trying lots of things, like 
> down grading qemu-kvm (which fixed it when I upgraded via the CR 
> repository and didn't this time), cloning a VM, and even beginning 
> to create new VM to restore from backup.
> Luckily I discovered that there is a log for each VM and found in 
> each case it failed because vmvga is not compiled into KVM.  So I 
> changed them all to cirrus via virt-manager and they all work again.
> The host machine is all up to date and all of the guest start and 
> operate as usual.

What worked for me was running "virsh edit" against each (now 
shutdown) domain, removing all the <address> tags in the <devices> 
section, e.g.,

       <address type='pci' .../>
       <address type='pci' .../>
       <address type='pci' .../>

All the VMs started without any issue after that, though I'll admit 
have haven't tried re-starting them since the fix.

Paul Heinlein <> heinlein at madboa.com <> http://www.madboa.com/